PHP 和 WordPress 版本检查主题

PHP和WordPress版本检查即将进入WordPress主题系统。该功能三天前被引入了核心WordPress。这将阻止最终用户安装或激活与其当前版本的PHP或WordPress不兼容的主题。更改预计将在WordPress 5.5中进行。

长期以来,此功能一直存在于许多主题作者的愿望清单中,尤其是PHP版本检查。插件作者获得了从WordPress 5.2开始支持特定PHP版本的能力。但是,在添加核心功能时,主题作者感觉像平常的二等公民一样,耐心等待插件作者收到了他们期待的新的闪亮工具。

以前,用于在各个主题内手动处理版本检查的代码比在插件中复杂。主题作者需要在主题切换后运行兼容性检查,并使用两种不同的方法来阻止自定义程序中的主题预览,具体取决于用户的WordPress版本。假设主题作者涵盖了所有基础。

在安装并尝试激活主题之前,用户没有真正的方式知道主题是否可以在其站点上使用。即使主题对于最终用户来说还是失败了,这也是糟糕的用户体验。

这种用户体验还阻碍了一些主题作者从过渡到PHP的较新版本。多年来,许多人都支持PHP 5.2。慢慢地,这些相同的作者中的一些人现在正在向更新的功能迈进,直到PHP 5.6,这是WordPress支持的最低功能。但是,很少有人跳到PHP 7和更高版本。

到目前为止,还没有一种机制可以让用户知道他们需要升级PHP才能使用特定主题。

一些主题作者可能会选择继续支持旧版本的PHP(例如5.6),以扩大潜在的用户群。但是,想要切换到较新功能的开发人员现在可以在核心平台的支持下这样做。

用户变更

WordPress.org主题存储库中的20个主题页面。

新的WordPress和PHP版本添加到了Twenty Twenty主题。

浏览WordPress主题目录的用户可能会开始注意到可用于某些主题的新信息。与插件类似,访问者应该会看到针对某些主题列出的WordPress版本和PHP版本。例如,“ Twenty Twenty”主题现在列出

以下最低要求:

  • WordPress版本: 4.7或更高
  • PHP版本: 5.2.4或更高版本

并非所有主题都会列出这些数字。用填充这些字段所需的数据更新旧主题需要一些时间。

在WordPress 5.5中,主题的管理界​​面将更改。尝试安装或激活主题时,WordPress将阻止此类操作。如果用户搜索的主题具有不兼容的WordPress或PHP版本,则正常安装按钮将替换为禁用按钮,显示为“无法安装”。如果已安装主题但未激活,则激活链接将类似地被禁用的“无法激活”按钮代替。也将不允许用户实时预览不兼容的主题。

尝试在没有PHP支持的情况下激活Twenty Twenty主题。

无法使用不兼容的PHP版本激活Twenty Twenty主题。

该功能在自定义程序界面中的功能与在WordPress管理员中通过主题屏幕的功能相同。

主题作者的更改

WordPress主题团队最近宣布了两个新的必需标题,供主题作者放置在其style.css文件中。第一个必填字段是Tested up to,这是主题经过测试的WordPress的最新版本。第二个Requires PHP字段是主题支持的最低PHP版本。

目前尚不清楚团队为何决定要求这两个字段,但不要求该Requires at least字段,它代表所需的最低WordPress版本。主题作者很可能希望将所有三个标题都放置在主题中。

仍将支持5.5之前的WordPress版本的主题作者希望继续使用其旧的兼容性检查。但是,这是逐步淘汰此类代码的第一步。


1. 本站所有信息来自网络,版权争议与本站无关,如有侵权请邮件联系站长!
2. 分享目的仅供大家学习和交流,请不要用于商业用途!否则,一切后果请用户自负。
3. 如果您喜欢网站的资源,资金许可的情况下,请支持正版,得到更好的正版服务。
4. 本站提供的各种资源,(源码/插件/模板)等都不包含技术服务,请大家谅解!
5. 网站资源如有链接无法下载、失效或广告,请联系客服或是留言进行处理!
6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!
7.如果你也有好的各种资源,联系在线客服均有额外收入!
学习园地-营销书籍|潜意识音乐|培训课程|电子书籍 » PHP 和 WordPress 版本检查主题

发表评论

在线客服
在线客服
旺旺客服
紧急联络